Get in touch
Back
Maintenance

Learning is currently undergoing maintenance

Completed 26 Apr at 03:45pm CEST.

Learning
Completed

Maintenance completed

Posted 26 Apr at 03:45pm CEST.
Started

Some users may experience issues when looking to complete courses or learning materials while this maintenance is carried out.

Posted 21 Apr at 03:45pm CEST.